Multi-file rips (i.e. cd1, cd2, etc.)

Oct 31, 2010 at 10:05 AM

I would like to make a prodcut suggestion:

Allow an option to define how to name multi-file rips, instead of an arbitrary dash and title casing the suffix.

For instance, I prefer to use {movieName}.({year}).cd{part#} as my template:

The Godfather.(1972).cd1.avi, The Godfather.(1972).cd2.avi, and so forth.

If this is possible, it would be very much appreciated, just to save me having to manually rename the files - even if FreQi does think it means I am being 'lazy and sloppy' :)

Still much thanks for the work you guys are doing!


Oct 31, 2010 at 2:17 PM

it can be done, but then there would be no limit on providing smallest customizations possible. The base architechture in MediaScout 3.0 is adopted from the previous releases, which wasnt that robust, thats why we moved to the MediaScout 4.0 development in parrallel with completely new architechture. Since its development will take time, and to provide community with optimizations, we are still porting updates to previous versions. Keeping it short, u will the option in MediaScout 4. I would recommend right now, just to download the code and make changes to following file MediaScoutLibray->MovieScout.cpp. You dont have to be programmer to do the same, just simple text changes and build the executable.

Nov 5, 2010 at 12:00 PM

Heh, where did I say that was lazy and sloppy?  That doesn't sound like something I would say about people sticking to a naming convention.

Nov 5, 2010 at 2:19 PM

in the Paul-vNext branch, TVScout.cs, line 127:

                                //FreQi - If we don't already have a folder, we'll have to create it.  I figure
                                // if users don't like the zero padded convention I've set here, they'll just have
                                // to rename the folder themselves and stop being so lazy and sloppy.  heh.
                                if (seasonFolder == null)
                                    seasonFolder = options.SeasonFolderName + " " + seasonID.PadLeft(2, '0');

I thought it was funny, didn't mean to start anything! And I did take it out of context, but it begged for it!


Nov 6, 2010 at 4:02 PM

Ahhhhh, that's where it is.  Yes that was me saying people that drop episodes in the series folder instead of a season folder are lazy/sloppy and if they don't like the zero padding on my season numbering they wouldn't really care anyway, and if they did, then they should have taken care of it already so too bad. ;]

I am not used to people actually reading the code/comments, you caught me by surprise!