metadata problems with every TV episode

Aug 1, 2010 at 10:19 PM

I am loving the new v2.0.7 but am having an issue when it comes to metadata for TV episodes

Everything runs smoothly except for metadata retrival..  everytime I recieve this "Could not find a part of the path 'E:\TV\{show}\{season}\metadata\{episode name}\metadata.xml'.  I manually fixed this by creating the {episode name} folder in my {season}\metadata since it did not exist.  Upon that correction I recieve this "Saving Episode Poster as {xx}.jpg : Could not find a part of the path 'E:\TV\{shoe}\{season}\metadata\metadata\{xx}.jpg'."..  Which I also manually fixed by creating the nested metadata foler in {season}\metadata since it also didnt exist...

I dont really feel I should have to create all these folders XD so a fix would be appreciated.  Below are excerpts of the errors I recieved and subsquentially fixed.

I sucessfully used 0.9 b2a which just dumped all metadata in the {season}\metadata folder which works for me but I'm not sure whats wrong with 2.0.7.. or what I am doing wrong

 And I know I cant spell.. sorry

After first correction
Processing File : Archer -2009- - S1E01 - Mole Hunt.mkv : Season : 1, Episode : 1
                    Saving Metadata as Archer -2009- - S1E01 - Mole Hunt\metadata.xml : Done

                    Saving Episode Poster as 1555111.jpg : Could not find a part of the path 'E:\TV\Archer (2009)\Season 1\metadata\metadata\1555111.jpg'.
Processing File : Archer -2009- - S1E02 - Training Day.mkv : Season : 1, Episode : 2

                    Saving Metadata as Archer -2009- - S1E02 - Training Day\metadata.xml

                Could not find a part of the path 'E:\TV\Archer (2009)\Season 1\metadata\Archer -2009- - S1E02 - Training Day\metadata.xml'.

After second correction
Processing File : Archer -2009- - S1E01 - Mole Hunt.mkv : Season : 1, Episode : 1

                    Saving Metadata as Archer -2009- - S1E01 - Mole Hunt\metadata.xml : Already Exists, skipping

                    Saving Episode Poster as 1555111.jpg : Done
Processing File : Archer -2009- - S1E02 - Training Day.mkv : Season : 1, Episode : 2

                    Saving Metadata as Archer -2009- - S1E02 - Training Day\metadata.xml

                Could not find a part of the path 'E:\TV\Archer (2009)\Season 1\metadata\Archer -2009- - S1E02 - Training Day\metadata.xml'.

Aug 1, 2010 at 10:33 PM

and upon slightly further investigation the episode poster going in the {season}\metadata\metadata folder wont load....

Aug 3, 2010 at 8:21 PM
Edited Aug 3, 2010 at 8:34 PM

I am getting the same error. when I process a season of any of my TV.

Processing File : Bones.S05E22.HDTV.XviD-LOL.avi : Season : 5, Episode : 22
                    Renaming Bones.S05E22.HDTV.XviD-LOL.avi to : Bones-S05E22 The Beginning in the End.avi
                    Saving Metadata as Bones-S05E22 The Beginning in the End.nfo : Done
                    Saving Metadata as Bones-S05E22 The Beginning in the End\metadata.xml
                Could not find a part of the path 'E:\TV\Bones\Season 05\metadata\Bones-S05E22 The Beginning in the End\metadata.xml'.

What I found is that in the metadata folder, it is not creating a folder for each episode, so it can not place the metadata.xml file correctly.

When I create the folders manually and reprocess the season, it places the metadata.xml file just fine.

 

My question is why is it not creating the episode folder within the metadata folder automatically?

Aug 3, 2010 at 8:42 PM

Another update on my error. when I create the episode folders. it process the metadata.xml... but it is failing to download the episode poster, because it wants another layer of metadata folder.
                Processing File : Burn Notice-S04E07 Past & Future Tense.avi : Season : 4, Episode : 7
                    Saving Metadata as Burn Notice-S04E07 Past & Future Tense.nfo : Done
                    Saving Metadata as Burn Notice-S04E07 Past & Future Tense\metadata.xml : Done
                    Saving Episode Poster as Burn Notice-S04E07 Past & Future Tense.tbn : Done
                    Saving Episode Poster as 2408571.jpg : Could not find a part of the path 'E:\TV\Burn Notice\Season 04\metadata\metadata\2408571.jpg'.

any ideas would be great.

Aug 3, 2010 at 9:00 PM
Well if you take the next step as I did and make the nested metadata
folder for the images it will put them there but the metadata.XML file
still looks for them in the root metadata folder... Only thing I can
think is someone made a slight typo in the code and it's adding extra
metadata cus logically the episode metadata shouldn't be in it's own
folder and the pics shouldn't be in a nested metadata folder.
Following the previous .9.b2a release the ep XML and pic should both
reside in the root metadata folder.

Sent from my iPhone
Aug 3, 2010 at 9:36 PM
Edited Aug 3, 2010 at 9:37 PM

went ahead an created the metadata folder for the episode posters, and it process fine...

so I guess my only question is why am I having to manually do this when processing phase moves all the files into this folder structure? It seem like it is missing some key pieces of code that create the structure if I am having to create all of these additional folders for it to work.

I mean I could be missing a setting, and if that is it then my bad, but I haven't seen anything in the options on how to get it to generate these folders.

Otherwise, I love the program it is the only thing I have folder that downloads TV information for my media server.

Aug 3, 2010 at 10:02 PM
Are your episode posters loading?

Sent from my iPhone

On Aug 3, 2010, at 4:36 PM, Plague1001 <notifications@codeplex.com> wrote:

From: Plague1001

went ahead an created the metadata folder for the episode posters, and it process fine...

so I guess my only question is why am I having to manually done then the process moves all the files into this folder structure? It seem like it is missing some key pieces of code that create the structure if I am having to create all of these additional folders for it to work.

I mean I could be missing a setting, and if that is it then my bad, but I haven't seen anything in the options on how to get it to generate these folders.

Otherwise, I love the program it is the only thing I have folder that downloads TV information for my media server.

Aug 3, 2010 at 10:44 PM

I know they are downloading, but I guess I don't know where they show up.

When I go into the season from in mediascout, the episode don't show a picture when being selected, so I guess that means they are not loading.

 

Aug 3, 2010 at 10:53 PM
Yea that was happening to me... Try moving the posters out of the second metadata folder and back to the root metadata folder where they should be

Sent from my iPhone

On Aug 3, 2010, at 5:44 PM, Plague1001 <notifications@codeplex.com> wrote:

From: Plague1001

I know they are downloading, but I guess I don't know where they show up.

When I go into the season from in mediascout, the episode don't show a picture when being selected, so I guess that means they are not loading.

 

Aug 3, 2010 at 11:10 PM

moved the images back one directory.

this is what I see when I view the season and episode list.

http://houseofzan.com/uploads/plague/season01.jpg

http://houseofzan.com/uploads/plague/episodelist.jpg

Coordinator
Aug 5, 2010 at 8:55 AM

Not sure what is causing the problem you have. Many issues would be fixed in the next release, 2.0.8. Stiil to debug your problem, make sure you have the following folder structure to fetch metadata for episodes.

<TV Show>\Season #\Episode.avi

Also, there is no metadata.xml file that is supposed to be downloaded for TV Episodes. I'll check for the bug if there is one with next release.

Aug 5, 2010 at 1:20 PM
My tv structure is indeed that, and the metadata.XML that is downloaded is placed in a folder named after the episode which is in the metadata folder, and the poster is placed in a nested metadata folder... I'm not sure how or where but in both cases its making something extra and it's metadata both times lol.  But I look forward to the next release which hopefully addresses this and the other problem in having where the program crashes when trying to dl multiple season posters for a season without any posters XD

Sent from my iPhone

On Aug 5, 2010, at 6:26 AM, "krishmav"<notifications@codeplex.com> wrote:

From: krishmav

Not sure what is causing the problem you have. Many issues would be fixed in the next release, 2.0.8. Stiil to debug your problem, make sure you have the following folder structure to fetch metadata for episodes.

<TV Show>\Season #\Episode.avi

Also, there is no metadata.xml file that is supposed to be downloaded for TV Episodes. I'll check for the bug if there is one with next release.

Aug 5, 2010 at 1:28 PM
And as it turns out it's also been fixed. Thanks
>
Aug 5, 2010 at 6:04 PM

Krishmav.

The structure of the folder is as you stated, and it is only the <TV Show>\Season #\metadata folder that has issues when processing.

the folder requires a folder for with the episode name, but I think the problem was that someone put an '\' in the wrong place, I think it is trying to do

<TV Show>\Season #\metadata\Episode Name metadata.xml but is it actually doing <TV Show>\Season #\metadata\Episode Name\metadata.xml

and the poster are doing

<TV Show>\Season #\metadata\metadata\postername.jpg but is should be doing <TV Show>\Season #\metadata\postername.jpg.

hope that helps explain the issues, if you need a log, I can post one.

any idea when I might be able to download 2.0.8, because it is not on the download site. I have a ton of TV that I am not processing because I am hoping for a fix.

Coordinator
Aug 6, 2010 at 6:55 AM

Bug has been corrected for new release. 2.0.8

Since the release is under development, with lot of features being added, its not yet stable, maybe a preview or beta release will be updated next week.

Aug 6, 2010 at 5:22 PM
Edited Aug 6, 2010 at 5:23 PM

very cool, thanks for fixing that. I am looking forward to its release. :)